about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index a2333fc..75fd790 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
 { mkShell, rustc, cargo, rust-analyzer, clippy, rustfmt
 , cargo-watch, cargo-edit, cargo-outdated, cargo-crev
 , xh, systemfd, tokio-console
-, pkg-config, protobuf
+, pkg-config, protobuf, typescript
 }:
 mkShell {
   name = "rust-dev-shell";
@@ -9,7 +9,7 @@ mkShell {
   nativeBuildInputs = [
     rustc cargo rust-analyzer clippy rustfmt
     cargo-watch cargo-edit cargo-outdated cargo-crev
-    xh systemfd #tokio-console
+    xh systemfd typescript #tokio-console
     # required for tokio-console's console-subscriber
     #pkg-config protobuf
   ];