about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index 32b6676..a2333fc 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
 { mkShell, rustc, cargo, rust-analyzer, clippy, rustfmt
 , cargo-watch, cargo-edit, cargo-outdated, cargo-crev
 , xh, systemfd, tokio-console
-, pkg-config, protobuf, openssl, zlib
+, pkg-config, protobuf
 }:
 mkShell {
   name = "rust-dev-shell";
@@ -9,11 +9,8 @@ mkShell {
   nativeBuildInputs = [
     rustc cargo rust-analyzer clippy rustfmt
     cargo-watch cargo-edit cargo-outdated cargo-crev
-    xh systemfd tokio-console
+    xh systemfd #tokio-console
     # required for tokio-console's console-subscriber
-    pkg-config protobuf
-    # required for httpmock, not actually used in the release
-    openssl.dev zlib
-
+    #pkg-config protobuf
   ];
 }