about summary refs log tree commit diff
path: root/nixos-tests/smoke-test.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos-tests/smoke-test.nix')
-rw-r--r--nixos-tests/smoke-test.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/nixos-tests/smoke-test.nix b/nixos-tests/smoke-test.nix
index b043a31..737dbab 100644
--- a/nixos-tests/smoke-test.nix
+++ b/nixos-tests/smoke-test.nix
@@ -1,11 +1,12 @@
-kittybox:
 { lib, ... }: {
   name = "nixos-kittybox";
 
   nodes = {
     kittybox = { config, pkgs, lib, ... }: {
-      imports = [ kittybox.nixosModules.default ];
+      imports = [ ../configuration.nix ];
 
+      # TODO: figure out if we can get rid of Postgres here
+      # even at the cost of Webmention functionality
       services.postgresql = {
         enable = true;
         ensureDatabases = ["kittybox"];