about summary refs log tree commit diff
path: root/kittybox-rs/indieauth/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'kittybox-rs/indieauth/Cargo.toml')
-rw-r--r--kittybox-rs/indieauth/Cargo.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/kittybox-rs/indieauth/Cargo.toml b/kittybox-rs/indieauth/Cargo.toml
index 80511f9..a81fd51 100644
--- a/kittybox-rs/indieauth/Cargo.toml
+++ b/kittybox-rs/indieauth/Cargo.toml
@@ -3,6 +3,10 @@ name = "kittybox-indieauth"
 version = "0.1.0"
 edition = "2021"
 
+[features]
+default = []
+axum = ["axum-core", "serde_json", "http"]
+
 [dev-dependencies]
 serde_json = "^1.0.64"       # A JSON serialization file format
 serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
@@ -16,3 +20,12 @@ features = ["serde"]
 [dependencies.serde]         # A generic serialization/deserialization framework
 version = "^1.0.125"
 features = ["derive"]
+[dependencies.axum-core]
+version = "^0.2.6"
+optional = true
+[dependencies.serde_json]
+version = "^1.0.64"
+optional = true
+[dependencies.http]
+version = "^0.2.7"
+optional = true
\ No newline at end of file