about summary refs log tree commit diff
path: root/kittybox-rs/indieauth/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'kittybox-rs/indieauth/Cargo.toml')
-rw-r--r--kittybox-rs/indieauth/Cargo.toml31
1 files changed, 0 insertions, 31 deletions
diff --git a/kittybox-rs/indieauth/Cargo.toml b/kittybox-rs/indieauth/Cargo.toml
deleted file mode 100644
index d6bc1fe..0000000
--- a/kittybox-rs/indieauth/Cargo.toml
+++ /dev/null
@@ -1,31 +0,0 @@
-[package]
-name = "kittybox-indieauth"
-version = "0.1.0"
-edition = "2021"
-
-[features]
-default = []
-axum = ["axum-core", "serde_json", "http"]
-
-[dev-dependencies]
-serde_json = "^1.0.64"       # A JSON serialization file format
-serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
-[dependencies]
-rand = "^0.8.5"              # Utilities for random number generation
-data-encoding = "^2.3.2"     # Efficient and customizable data-encoding functions like base64, base32, and hex
-sha2 = "^0.10.7"              # SHA-2 series of algorithms for Rust
-[dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
-version = "^2.2.1"
-features = ["serde"]
-[dependencies.serde]         # A generic serialization/deserialization framework
-version = "^1.0.170"
-features = ["derive"]
-[dependencies.axum-core]
-version = "^0.3.4"
-optional = true
-[dependencies.serde_json]
-version = "^1.0.64"
-optional = true
-[dependencies.http]
-version = "^0.2.7"
-optional = true
\ No newline at end of file