about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml7
1 files changed, 1 insertions, 6 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index 833785c..4ed65b3 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -45,7 +45,6 @@ features = ["axum"]
 [dev-dependencies]
 mockito = "^0.30.0"          # HTTP mocking for Rust.
 tempdir = "^0.3.7"           # A library for managing a temporary directory and deleting all contents when it's dropped
-test-logger = "^0.1.0"       # Simple helper to initialize env_logger before unit and integration tests
 httpmock = "^0.6"            # HTTP mocking library that allows you to simulate responses from HTTP based services
 faker_rand = "^0.1.1"        # Seedable, rand-compatible generators of fake data
 rand = "^0.8.5"              # Utilities for random number generation
@@ -62,7 +61,7 @@ futures-util = "^0.3.14"     # Common utilities and extension traits for the fut
 hex = "^0.4.3"
 lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in Rust
 listenfd = "^0.5.0"          # A simple library to work with listenfds passed from the outside (systemd/catflap socket activation)
-log = "^0.4.14"              # A lightweight logging facade for Rust
+#log = "^0.4.14"              # A lightweight logging facade for Rust
 markdown = "^0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
 newbase60 = "^0.1.3"         # A library that implements Tantek Çelik's New Base 60
 rand = "^0.8.4"              # Random number generators.
@@ -76,7 +75,6 @@ tracing-tree = "0.2.1"
 tracing-subscriber = { version = "0.3.11", features = ["env-filter", "json"] }
 tower-http = { version = "0.3.3", features = ["trace", "cors", "catch-panic"] }
 tower = { version = "0.4.12", features = ["tracing"] }
-tracing-log = "0.1.3"
 [dependencies.tokio]
 version = "^1.16.1"
 features = ["full", "tracing"] # TODO determine if my app doesn't need some features
@@ -110,9 +108,6 @@ features = ["derive"]
 [dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
 version = "^2.2.1"
 features = ["serde"]
-[dependencies.http-types]    # Common types for HTTP operations
-version = "^2.11.0"
-features = ["http"]
 [dependencies.hyper]
 version = "^0.14.17"
 features = ["stream", "runtime"]