about summary refs log tree commit diff
path: root/indieauth/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'indieauth/Cargo.toml')
-rw-r--r--indieauth/Cargo.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/indieauth/Cargo.toml b/indieauth/Cargo.toml
index 72b420a..7f18dfa 100644
--- a/indieauth/Cargo.toml
+++ b/indieauth/Cargo.toml
@@ -8,24 +8,24 @@ default = []
 axum = ["dep:axum-core", "dep:serde_json", "dep:http"]
 
 [dev-dependencies]
-serde_json = "^1.0.64"       # A JSON serialization file format
-serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
+serde_json = "^1.0.134"       # A JSON serialization file format
+serde_urlencoded = "^0.7.1"  # `x-www-form-urlencoded` meets Serde
 [dependencies]
 rand = "^0.8.5"              # Utilities for random number generation
-data-encoding = "^2.3.2"     # Efficient and customizable data-encoding functions like base64, base32, and hex
-sha2 = "^0.10.7"              # SHA-2 series of algorithms for Rust
+data-encoding = "^2.6.0"     # Efficient and customizable data-encoding functions like base64, base32, and hex
+sha2 = "^0.10.8"              # SHA-2 series of algorithms for Rust
 [dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
-version = "^2.2.1"
+version = "^2.5.4"
 features = ["serde"]
 [dependencies.serde]         # A generic serialization/deserialization framework
-version = "^1.0.170"
+version = "^1.0.217"
 features = ["derive"]
 [dependencies.axum-core]
-version = "^0.4.3"
+version = "^0.4.5"
 optional = true
 [dependencies.serde_json]
-version = "^1.0.64"
+version = "^1.0.134"
 optional = true
 [dependencies.http]
-version = "^1.0"
-optional = true
\ No newline at end of file
+version = "^1.2"
+optional = true