about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 5c3ed37..c4063b8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -25,6 +25,7 @@
     packages = {
       kittybox = pkgs.callPackage ./kittybox.nix {
         naersk = naersk.lib.${system};
+        inherit (pkgs.nodePackages) typescript;
       };
       default = self.packages.${system}.kittybox;
     };
@@ -40,6 +41,8 @@
       };
     };
 
-    devShells.default = pkgs.callPackage ./shell.nix {};
+    devShells.default = pkgs.callPackage ./shell.nix {
+      inherit (pkgs.nodePackages) typescript;
+    };
   });
 }