about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index c4063b8..908f778 100644
--- a/flake.nix
+++ b/flake.nix
@@ -13,6 +13,12 @@
       ref = "master";
       inputs.nixpkgs.follows = "nixpkgs";
     };
+    nixpkgs = {
+      type = "github";
+      owner = "nixos";
+      repo = "nixpkgs";
+      ref = "nixos-22.11";
+    };
   };
   outputs = { self, nixpkgs, flake-utils, naersk }: let
     supportedSystems = ["aarch64-linux" "x86_64-linux"];
@@ -42,7 +48,7 @@
     };
 
     devShells.default = pkgs.callPackage ./shell.nix {
-      inherit (pkgs.nodePackages) typescript;
+      inherit (pkgs.nodePackages) typescript typescript-language-server;
     };
   });
 }