about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 1 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index 165b386..5c3ed37 100644
--- a/flake.nix
+++ b/flake.nix
@@ -40,18 +40,6 @@
       };
     };
 
-    devShells.default = pkgs.mkShell {
-      name = "rust-dev-shell";
-
-      nativeBuildInputs = with pkgs; [
-        # required for tokio-console's console-subscriber
-        pkg-config protobuf
-        # required for httpmock, not actually used in the release
-        openssl.dev zlib
-        xh systemfd tokio-console
-        cargo-watch cargo-edit cargo-outdated
-        rustc cargo rust-analyzer clippy
-      ];
-    };
+    devShells.default = pkgs.callPackage ./shell.nix {};
   });
 }