about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index f820e51..81eee80 100644
--- a/flake.nix
+++ b/flake.nix
@@ -20,14 +20,14 @@
       overlays = [ rust-overlay.overlays.default ];
       localSystem = { inherit system; };
     };
+    # NOTE: `pkgs` here must match `pkgs` used for `callPackage` to ensure
+    # cross-compilation works. Crane sets the requisite variables automatically.
     crane' = crane.mkLib pkgs;
     cargoToml = builtins.fromTOML (builtins.readFile ./Cargo.toml);
     crane-msrv' = crane'.overrideToolchain (p: p.rust-bin.stable."${cargoToml.package.rust-version}".default);
 
     kittybox = pkgs.callPackage ./kittybox.nix {
-      # TODO: this may break cross-compilation. It may be better to
-      # inject it as an overlay. However, I am unsure whether Crane
-      # can recognize it's being passed a cross-compilation set.
+      # NOTE: See above re: cross-compilation.
       crane = crane';
 
       nixosTests = {