about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d4cfb72..e858f91 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,6 +3,7 @@ name = "kittybox"
 version = "0.1.0"
 authors = ["Vika <vika@fireburn.ru>"]
 edition = "2021"
+default-run = "kittybox"
 
 [features]
 default = []
@@ -43,6 +44,7 @@ fd-lock = "^3.0.0"           # Advisory reader-writer locks for files
 futures = "^0.3.14"          # An implementation of futures and streams
 futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
 lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in Rust
+listenfd = "^0.5.0"          # A simple library to work with listenfds passed from the outside (systemd/catflap socket activation)
 log = "^0.4.14"              # A lightweight logging facade for Rust
 markdown = "^0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
 markup = "^0.12.0"           # HTML templating engine... ok also very funny about markdown and markup... i just realized the pun...
@@ -53,9 +55,13 @@ serde_json = "^1.0.64"       # A JSON serialization file format
 serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
 relative-path = "^1.5.0"     # Portable relative paths for Rust
 sha2 = "^0.9.8"              # SHA-2 series of algorithms for Rust
+warp-prometheus = "^0.5.0"   # An afterthought of prometheus metrics for Warp
 [dependencies.tokio]
 version = "^1.16.1"
 features = ["full"] # TODO determine if my app doesn't need some features
+[dependencies.tokio-stream]
+version = "^0.1.8"
+features = ["time", "net"]
 [dependencies.anyhow]
 version = "^1.0.42"
 optional = true
@@ -67,7 +73,7 @@ version = "^0.21.3"
 optional = true
 features = ["aio", "tokio-comp"]
 [dependencies.prometheus]    # Prometheus instrumentation library for Rust applications
-version = "^0.12.0"
+version = "^0.13.0"
 features = ["process"]
 [dependencies.serde]         # A generic serialization/deserialization framework
 version = "^1.0.125"