about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 9 insertions, 6 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b07da8a..79f7107 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,23 +42,26 @@ retainer = "^0.2.2"          # Minimal async cache in Rust with support for key
 serde_json = "^1.0.64"       # A JSON serialization file format
 serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
 tide = "^0.16.0"             # A minimal and pragmatic Rust web application framework built for rapid development
-[dependencies.async-std]    # Async version of the Rust standard library
+[dependencies.anyhow]
+version = "^1.0.42"
+optional = true
+[dependencies.async-std]     # Async version of the Rust standard library
 version = "^1.9.0"
 features = ["attributes"]
-[dependencies.chrono]       # Date and time library for Rust
+[dependencies.chrono]        # Date and time library for Rust
 version = "^0.4.19"
 features = ["serde"]
-[dependencies.mobc-redis]   # Redis support for the mobc connection pool
+[dependencies.mobc-redis]    # Redis support for the mobc connection pool
 version = "^0.7.0"
 features = ["async-std-comp"]
 default-features = false
-[dependencies.serde]        # A generic serialization/deserialization framework
+[dependencies.serde]         # A generic serialization/deserialization framework
 version = "^1.0.125"
 features = ["derive"]
-[dependencies.surf]         # Surf the web - HTTP client framework
+[dependencies.surf]          # Surf the web - HTTP client framework
 version = "^2.2.0"
 default-features = false
 features = ["h1-client-rustls", "encoding", "middleware-logger"]
-[dependencies.url]          # URL library for Rust, based on the WHATWG URL Standard
+[dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
 version = "^2.2.1"
 features = ["serde"]