about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml52
1 files changed, 26 insertions, 26 deletions
diff --git a/Cargo.toml b/Cargo.toml
index de17d38..52095fb 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,45 +7,45 @@ edition = "2018"
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dev-dependencies]
-tide-testing = "0.1.3"      # tide testing helper
-mockito = "0.30.0"          # HTTP mocking for Rust.
-tempdir = "0.3.7"           # A library for managing a temporary directory and deleting all contents when it's dropped
+tide-testing = "^0.1.3"      # tide testing helper
+mockito = "^0.30.0"          # HTTP mocking for Rust.
+tempdir = "^0.3.7"           # A library for managing a temporary directory and deleting all contents when it's dropped
 
 [dependencies]
-async-trait = "0.1.50"      # Type erasure for async trait methods
-easy-scraper = "0.2.0"      # HTML scraping library focused on ease of use
-ellipse = "0.2.0"           # Truncate and ellipsize strings in a human-friendly way
-env_logger = "0.8.3"        # A logging implementation for `log` which is configured via an environment variable
-futures = "0.3.14"          # An implementation of futures and streams
-futures-util = "0.3.14"     # Common utilities and extension traits for the futures-rs library
-http-types = "2.11.0"       # Common types for HTTP operations
-lazy_static = "1.4.0"       # A macro for declaring lazily evaluated statics in Rust
-log = "0.4.14"              # A lightweight logging facade for Rust
-markdown = "0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
-markup = "0.12.0"           # HTML templating engine... ok also very funny about markdown and markup... i just realized the pun...
-mobc = "0.7.2"              # A generic connection pool with async/await support
-newbase60 = "0.1.3"         # A library that implements Tantek Çelik's New Base 60
-retainer = "0.2.2"          # Minimal async cache in Rust with support for key expirations
-serde_json = "1.0.64"       # A JSON serialization file format
-serde_urlencoded = "0.7.0"  # `x-www-form-urlencoded` meets Serde
-tide = "0.16.0"             # A minimal and pragmatic Rust web application framework built for rapid development
+async-trait = "^0.1.50"      # Type erasure for async trait methods
+easy-scraper = "^0.2.0"      # HTML scraping library focused on ease of use
+ellipse = "^0.2.0"           # Truncate and ellipsize strings in a human-friendly way
+env_logger = "^0.8.3"        # A logging implementation for `log` which is configured via an environment variable
+futures = "^0.3.14"          # An implementation of futures and streams
+futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
+http-types = "^2.11.0"       # Common types for HTTP operations
+lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in Rust
+log = "^0.4.14"              # A lightweight logging facade for Rust
+markdown = "^0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
+markup = "^0.12.0"           # HTML templating engine... ok also very funny about markdown and markup... i just realized the pun...
+mobc = "^0.7.2"              # A generic connection pool with async/await support
+newbase60 = "^0.1.3"         # A library that implements Tantek Çelik's New Base 60
+retainer = "^0.2.2"          # Minimal async cache in Rust with support for key expirations
+serde_json = "^1.0.64"       # A JSON serialization file format
+serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
+tide = "^0.16.0"             # A minimal and pragmatic Rust web application framework built for rapid development
 [dependencies.async-std]    # Async version of the Rust standard library
-version = "1.9.0"
+version = "^1.9.0"
 features = ["attributes"]
 [dependencies.chrono]       # Date and time library for Rust
-version = "0.4.19"
+version = "^0.4.19"
 features = ["serde"]
 [dependencies.mobc-redis]   # Redis support for the mobc connection pool
-version = "0.7.0"
+version = "^0.7.0"
 features = ["async-std-comp"]
 default-features = false
 [dependencies.serde]        # A generic serialization/deserialization framework
-version = "1.0.125"
+version = "^1.0.125"
 features = ["derive"]
 [dependencies.surf]         # Surf the web - HTTP client framework
-version = "2.2.0"
+version = "^2.2.0"
 default-features = false
 features = ["h1-client-rustls", "encoding", "middleware-logger"]
 [dependencies.url]          # URL library for Rust, based on the WHATWG URL Standard
-version = "2.2.1"
+version = "^2.2.1"
 features = ["serde"]