about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 4 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 88eb6d6..d4cfb72 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,7 +42,6 @@ env_logger = "^0.8.3"        # A logging implementation for `log` which is confi
 fd-lock = "^3.0.0"           # Advisory reader-writer locks for files
 futures = "^0.3.14"          # An implementation of futures and streams
 futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
-http-types = "^2.11.0"       # Common types for HTTP operations
 lazy_static = "^1.4.0"       # A macro for declaring lazily evaluated statics in Rust
 log = "^0.4.14"              # A lightweight logging facade for Rust
 markdown = "^0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
@@ -80,10 +79,13 @@ features = ["serde"]
 version = "^0.3.2"
 default-features = false
 features = ["multipart", "compression"]
+[dependencies.http-types]    # Common types for HTTP operations
+version = "^2.11.0"
+features = ["http"]
 [dependencies.hyper]
 version = "^0.14.17"
 features = ["client", "stream", "runtime"]
 [dependencies.hyper-rustls]
 version = "^0.23.0"
 default-features = false
-features = ["webpki-tokio", "http1", "http2", "tls12", "logging"]
\ No newline at end of file
+features = ["webpki-tokio", "http1", "http2", "tls12", "logging"]