about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 43033f5..83ff9ab 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,6 +14,7 @@ tempdir = "0.3.7"           # A library for managing a temporary directory and d
 [dependencies]
 async-trait = "0.1.50"      # Type erasure for async trait methods
 easy-scraper = "0.2.0"      # HTML scraping library focused on ease of use
+ellipse = "0.2.0"           # Truncate and ellipsize strings in a human-friendly way
 env_logger = "0.8.3"        # A logging implementation for `log` which is configured via an environment variable
 futures = "0.3.14"          # An implementation of futures and streams
 futures-util = "0.3.14"     # Common utilities and extension traits for the futures-rs library
@@ -21,6 +22,7 @@ http-types = "2.11.0"       # Common types for HTTP operations
 lazy_static = "1.4.0"       # A macro for declaring lazily evaluated statics in Rust
 log = "0.4.14"              # A lightweight logging facade for Rust
 markdown = "0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
+markup = "0.12.0"           # HTML templating engine... ok also very funny about markdown and markup... i just realized the pun...
 mobc = "0.7.2"              # A generic connection pool with async/await support
 newbase60 = "0.1.3"         # A library that implements Tantek Çelik's New Base 60
 retainer = "0.2.2"          # Minimal async cache in Rust with support for key expirations