about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 73ee6ed..3974d9c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -23,12 +23,15 @@ required-features = ["util"]
 tide-testing = "^0.1.3"      # tide testing helper
 mockito = "^0.30.0"          # HTTP mocking for Rust.
 tempdir = "^0.3.7"           # A library for managing a temporary directory and deleting all contents when it's dropped
+paste = "^1.0.5"             # Macros for all your token pasting needs
+test-logger = "^0.1.0"       # Simple helper to initialize env_logger before unit and integration tests
 
 [dependencies]
 async-trait = "^0.1.50"      # Type erasure for async trait methods
 easy-scraper = "^0.2.0"      # HTML scraping library focused on ease of use
 ellipse = "^0.2.0"           # Truncate and ellipsize strings in a human-friendly way
 env_logger = "^0.8.3"        # A logging implementation for `log` which is configured via an environment variable
+fd-lock = "^3.0.0"           # Advisory reader-writer locks for files
 futures = "^0.3.14"          # An implementation of futures and streams
 futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
 http-types = "^2.11.0"       # Common types for HTTP operations
@@ -47,7 +50,7 @@ version = "^1.0.42"
 optional = true
 [dependencies.async-std]     # Async version of the Rust standard library
 version = "^1.9.0"
-features = ["attributes"]
+features = ["attributes", "unstable"]
 [dependencies.chrono]        # Date and time library for Rust
 version = "^0.4.19"
 features = ["serde"]