about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 11 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f8dbd6a..eaaac7b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -24,6 +24,16 @@ name = "kittybox-database-converter"
 path = "src/bin/kittybox_database_converter.rs"
 required-features = ["util", "redis"]
 
+[workspace]
+members = [".", "./util", "./templates"]
+default-members = [".", "./util", "./templates"]
+[dependencies.kittybox-util]
+version = "0.1.0"
+path = "./util"
+[dependencies.kittybox-templates]
+version = "0.1.0"
+path = "./templates"
+
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
 
 [dev-dependencies]
@@ -39,7 +49,6 @@ bytes = "^1.1.0"
 data-encoding = "^2.3.2"     # Efficient and customizable data-encoding functions like base64, base32, and hex
 easy-scraper = "^0.2.0"      # HTML scraping library focused on ease of use
 either = "^1.6.1"            # A general purpose sum type with two cases
-ellipse = "^0.2.0"           # Truncate and ellipsize strings in a human-friendly way
 env_logger = "^0.8.3"        # A logging implementation for `log` which is configured via an environment variable
 futures = "^0.3.14"          # An implementation of futures and streams
 futures-util = "^0.3.14"     # Common utilities and extension traits for the futures-rs library
@@ -102,4 +111,4 @@ features = ["webpki-tokio", "http1", "http2", "tls12", "logging"]
 [dependencies.reqwest]
 version = "^0.11.10"
 default-features = false
-features = ["rustls-tls-webpki-roots", "gzip", "brotli", "json", "stream"]
+features = ["rustls-tls-webpki-roots", "gzip", "brotli", "json", "stream"]
\ No newline at end of file