about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml52
1 files changed, 43 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 3e085db..141016e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,7 +14,11 @@ unexpected_cfgs = { level = "warn", check-cfg = ['cfg(tokio_unstable)'] }
 [features]
 default = ["rustls", "postgres"]
 webauthn = ["openssl", "dep:webauthn"]
-openssl = ["reqwest/native-tls", "reqwest/native-tls-alpn", "sqlx/tls-native-tls"]
+openssl = [
+    "reqwest/native-tls",
+    "reqwest/native-tls-alpn",
+    "sqlx/tls-native-tls",
+]
 rustls = ["reqwest/rustls-tls-webpki-roots", "sqlx/tls-rustls"]
 cli = ["dep:clap", "dep:anyhow"]
 postgres = ["sqlx", "kittybox-util/sqlx"]
@@ -123,7 +127,11 @@ wiremock = "0.6.2"
 anyhow = { version = "1.0.95", optional = true }
 argon2 = { version = "0.5.3", features = ["std"] }
 axum = { workspace = true, features = ["multipart", "json", "form", "macros"] }
-axum-extra = { version = "0.10.0", features = ["cookie", "cookie-signed", "typed-header"] }
+axum-extra = { version = "0.10.0", features = [
+    "cookie",
+    "cookie-signed",
+    "typed-header",
+] }
 bytes = "1.9.0"
 chrono = { workspace = true }
 clap = { workspace = true, features = ["derive"], optional = true }
@@ -132,7 +140,9 @@ either = "1.13.0"
 futures = { workspace = true }
 futures-util = { workspace = true }
 html5ever = "=0.27.0"
-http-cache-reqwest = { version = "0.15.0", default-features = false, features = ["manager-moka"] }
+http-cache-reqwest = { version = "0.15.0", default-features = false, features = [
+    "manager-moka",
+] }
 hyper = "1.5.2"
 lazy_static = "1.5.0"
 listenfd = "1.0.1"
@@ -142,27 +152,51 @@ mime = "0.3.17"
 newbase60 = "0.1.4"
 prometheus = { version = "0.13.4", features = ["process"] }
 rand = { workspace = true }
-redis = { version = "0.27.6", features = ["aio", "tokio-comp"], optional = true }
+redis = { version = "0.27.6", features = [
+    "aio",
+    "tokio-comp",
+], optional = true }
 relative-path = "1.9.3"
-reqwest = { version = "0.12.12", default-features = false, features = ["gzip", "brotli", "json", "stream"] }
+reqwest = { version = "0.12.12", default-features = false, features = [
+    "gzip",
+    "brotli",
+    "json",
+    "stream",
+] }
 reqwest-middleware = "0.4.0"
 serde = { workspace = true }
 serde_json = { workspace = true }
 serde_urlencoded = { workspace = true }
 serde_variant = { workspace = true }
 sha2 = { workspace = true }
-sqlparser = { version = "0.53.0", features = ["serde", "serde_json"], optional = true }
-sqlx = { workspace = true, features = ["uuid", "chrono", "postgres", "runtime-tokio"], optional = true }
+sqlparser = { version = "0.53.0", features = [
+    "serde",
+    "serde_json",
+], optional = true }
+sqlx = { workspace = true, features = [
+    "uuid",
+    "chrono",
+    "postgres",
+    "runtime-tokio",
+], optional = true }
 thiserror = { workspace = true }
 tokio = { workspace = true, features = ["full", "tracing"] }
 tokio-stream = { workspace = true, features = ["time", "net"] }
 tokio-util = { workspace = true, features = ["io-util"] }
 tower = { workspace = true, features = ["tracing"] }
-tower-http = { version = "0.6.2", features = ["trace", "cors", "catch-panic", "sensitive-headers", "set-header"] }
+tower-http = { version = "0.6.2", features = [
+    "trace",
+    "cors",
+    "catch-panic",
+    "sensitive-headers",
+    "set-header",
+] }
 tracing = { workspace = true, features = [] }
 tracing-log = { workspace = true }
 tracing-subscriber = { workspace = true, features = ["env-filter", "json"] }
 tracing-tree = { workspace = true }
 url = { workspace = true }
 uuid = { workspace = true, features = ["v4"] }
-webauthn = { version = "0.5.0", package = "webauthn-rs", features = ["danger-allow-state-serialisation"], optional = true }
+webauthn = { version = "0.5.0", package = "webauthn-rs", features = [
+    "danger-allow-state-serialisation",
+], optional = true }