about summary refs log tree commit diff
path: root/templates/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-29 21:59:56 +0300
committerVika <vika@fireburn.ru>2023-07-29 21:59:56 +0300
commit0617663b249f9ca488e5de652108b17d67fbaf45 (patch)
tree11564b6c8fa37bf9203a0a4cc1c4e9cc088cb1a5 /templates/Cargo.toml
parent26c2b79f6a6380ae3224e9309b9f3352f5717bd7 (diff)
Moved the entire Kittybox tree into the root
Diffstat (limited to 'templates/Cargo.toml')
-rw-r--r--templates/Cargo.toml33
1 files changed, 33 insertions, 0 deletions
diff --git a/templates/Cargo.toml b/templates/Cargo.toml
new file mode 100644
index 0000000..38e73b3
--- /dev/null
+++ b/templates/Cargo.toml
@@ -0,0 +1,33 @@
+[package]
+name = "kittybox-frontend-renderer"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[build-dependencies]
+libflate = "^2.0.0"
+walkdir = "^2.3.2"
+
+[dev-dependencies]
+faker_rand = "^0.1.1"
+rand = "^0.8.5"
+[dev-dependencies.microformats]
+version="^0.3.0"
+
+[dependencies]
+ellipse = "^0.2.0"
+http = "^0.2.7"
+markup = "^0.13.1"
+serde_json = "^1.0.64"
+include_dir = "^0.7.2"
+axum = "^0.6.18"
+[dependencies.chrono]
+version = "^0.4.19"
+features = ["serde"]
+[dependencies.kittybox-util]
+version = "0.1.0"
+path = "../util"
+[dependencies.kittybox-indieauth]
+version = "0.1.0"
+path = "../indieauth"
\ No newline at end of file