about summary refs log tree commit diff
path: root/smoke-test.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-08-13 22:33:38 +0300
committerVika <vika@fireburn.ru>2022-08-13 22:36:13 +0300
commit629531bdefad41e8839fa818e68bcf9a083466f8 (patch)
tree65c9bb8a5e51bcbadeded91e15b694482c075c21 /smoke-test.nix
parent8a6447c8aabb36ec4a8e66c61c058fbf36727802 (diff)
NixOS module fixes and temporary fixes to the legacy configuration
Diffstat (limited to 'smoke-test.nix')
-rw-r--r--smoke-test.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/smoke-test.nix b/smoke-test.nix
index 3965e7b..df7583e 100644
--- a/smoke-test.nix
+++ b/smoke-test.nix
@@ -8,11 +8,6 @@ kittybox:
 
       services.kittybox = {
         enable = true;
-        # It never actually contacts those endpoints anyway unless we use Micropub so it's fine!
-        # TODO: Once we have self-hosted software for those endpoints,
-        #       make an e2e test for common workflows (e.g. making a post)
-        tokenEndpoint = "https://example.com";
-        authorizationEndpoint = "https://example.com";
         logLevel = "info,kittybox=debug,retainer::cache=warn,h2=warn,rustls=warn";
       };
 
@@ -22,6 +17,9 @@ kittybox:
     };
   };
 
+  # TODO: Make e2e tests for authentication endpoints and such
+  # Potentially using WebDriver
+  # Could also be implemented with fantoccini
   testScript = ''
     with subtest("Verify that Kittybox started correctly..."):
         kittybox.wait_for_open_port(8080)