about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-06-22 20:18:30 +0300
committerVika <vika@fireburn.ru>2023-06-22 20:18:30 +0300
commit8b1f39e5b30b5a3bad0f95d92a5909992139aca2 (patch)
tree70486888c96a76b77f084c37e1ef0d22148e4ee9 /shell.nix
parent775693f36d96c304ff1cb76e0dea78d61d82903e (diff)
[wip] Postgres backend
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 91b2c54..e22e25f 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
 { mkShell, rustc, cargo, rust-analyzer, clippy, rustfmt
 , cargo-watch, cargo-edit, cargo-outdated
 , cargo-crev, cargo-audit
-, xh, systemfd, tokio-console
+, xh, systemfd, tokio-console, sqlx-cli
 , pkg-config, protobuf, typescript, typescript-language-server
 }:
 mkShell {
@@ -10,7 +10,7 @@ mkShell {
   nativeBuildInputs = [
     rustc cargo rust-analyzer clippy rustfmt
     cargo-watch cargo-edit cargo-outdated
-    cargo-crev cargo-audit
+    cargo-crev cargo-audit sqlx-cli
     xh systemfd typescript typescript-language-server
     #tokio-console
     # required for tokio-console's console-subscriber