about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-09-28 23:13:02 +0300
committerVika <vika@fireburn.ru>2022-09-28 23:13:02 +0300
commitc35a55babd9aa6e1ad8797f3d54deec2f78ff78a (patch)
tree742023e1d1e75601b7f7cc4020b53938e82416d8 /shell.nix
parentf420c7fd09b0f9ef82784a9c49889f620e73e886 (diff)
downloadkittybox-c35a55babd9aa6e1ad8797f3d54deec2f78ff78a.tar.zst
Switch to TypeScript
This neccesitates installing TypeScript to build Kittybox, but
thankfully Nix actually takes care of that. Build Kittybox with Nix
and you won't have problems.

Also now I can safely do stuff.
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index a2333fc..75fd790 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
 { mkShell, rustc, cargo, rust-analyzer, clippy, rustfmt
 , cargo-watch, cargo-edit, cargo-outdated, cargo-crev
 , xh, systemfd, tokio-console
-, pkg-config, protobuf
+, pkg-config, protobuf, typescript
 }:
 mkShell {
   name = "rust-dev-shell";
@@ -9,7 +9,7 @@ mkShell {
   nativeBuildInputs = [
     rustc cargo rust-analyzer clippy rustfmt
     cargo-watch cargo-edit cargo-outdated cargo-crev
-    xh systemfd #tokio-console
+    xh systemfd typescript #tokio-console
     # required for tokio-console's console-subscriber
     #pkg-config protobuf
   ];