about summary refs log tree commit diff
path: root/nixos-tests/webmention-test.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-05-19 01:27:56 +0300
committerVika <vika@fireburn.ru>2024-05-19 01:27:56 +0300
commit113a6f9fe6603be7488c1c9a5bb4b1b7c5bb2f71 (patch)
tree2d123cbe52f96cc1e470b754bb92d22776cb12df /nixos-tests/webmention-test.nix
parent9821be44cfdcbdc9c5a37b8eabddccabe0cbeabf (diff)
Move NixOS test initialization to the package
This allows to initialize tests easier and not have them depend on the
flake itself. This might be useful if I ever have to build this
package without a flake.
Diffstat (limited to 'nixos-tests/webmention-test.nix')
-rw-r--r--nixos-tests/webmention-test.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/nixos-tests/webmention-test.nix b/nixos-tests/webmention-test.nix
index 45e3ff7..314b3d4 100644
--- a/nixos-tests/webmention-test.nix
+++ b/nixos-tests/webmention-test.nix
@@ -1,4 +1,3 @@
-kittybox:
 { lib, ... }: let
   hosts = ''
     192.168.2.101 kittybox.test
@@ -9,7 +8,7 @@ in {
 
   nodes = {
     kittybox = { config, pkgs, lib, ... }: {
-      imports = [ kittybox.nixosModules.default ];
+      imports = [ ../configuration.nix ];
 
       services.postgresql = {
         enable = true;