about summary refs log tree commit diff
path: root/nixos-tests/distributed-test.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2024-05-19 01:27:56 +0300
committerVika <vika@fireburn.ru>2024-05-19 01:27:56 +0300
commit113a6f9fe6603be7488c1c9a5bb4b1b7c5bb2f71 (patch)
tree2d123cbe52f96cc1e470b754bb92d22776cb12df /nixos-tests/distributed-test.nix
parent9821be44cfdcbdc9c5a37b8eabddccabe0cbeabf (diff)
Move NixOS test initialization to the package
This allows to initialize tests easier and not have them depend on the
flake itself. This might be useful if I ever have to build this
package without a flake.
Diffstat (limited to 'nixos-tests/distributed-test.nix')
-rw-r--r--nixos-tests/distributed-test.nix3
1 files changed, 1 insertions, 2 deletions
diff --git a/nixos-tests/distributed-test.nix b/nixos-tests/distributed-test.nix
index 11c2dba..5e43bbf 100644
--- a/nixos-tests/distributed-test.nix
+++ b/nixos-tests/distributed-test.nix
@@ -1,9 +1,8 @@
 # This doesn't seem to work for some reason. I wonder why.
 # The VMs themselves don't want to launch properly.
-kittybox:
 { lib, system, ... }: let
   kittyboxModule = { config, pkgs, lib, ... }: {
-    imports = [ kittybox.nixosModules.default commonModule ];
+    imports = [ ../configuration.nix commonModule ];
 
     services.kittybox = {
       enable = true;