about summary refs log tree commit diff
path: root/kittybox-rs/util/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-09 21:06:55 +0300
committerVika <vika@fireburn.ru>2023-07-09 21:06:55 +0300
commitb38b508366a80a2f1c163ae3623c79e883323201 (patch)
tree03d3ea5c90b9e64641b4d32c8accec5a2380e570 /kittybox-rs/util/Cargo.toml
parent89a35e9dbeb972b50008c7272a87f8eed5121d8c (diff)
webmentions/queue: move JobQueue trait into kittybox-util
The trait itself seems basic enough that it could be reused
elsewhere. Better to keep it in a separate crate.

`-util` is a dumping ground for various things anyway.
Diffstat (limited to 'kittybox-rs/util/Cargo.toml')
-rw-r--r--kittybox-rs/util/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/kittybox-rs/util/Cargo.toml b/kittybox-rs/util/Cargo.toml
index b0b725c..f0653db 100644
--- a/kittybox-rs/util/Cargo.toml
+++ b/kittybox-rs/util/Cargo.toml
@@ -13,6 +13,9 @@ serde = { version = "^1.0.125", features = ["derive"] }
 serde_json = "^1.0.64"
 axum-core = "^0.2.6"
 http = "^0.2.7"
+async-trait = "^0.1.50"
+futures-util = "^0.3.14"
+uuid = "^1.3.3"
 [dependencies.rand]
 version = "^0.8.5"
 optional = true