about summary refs log tree commit diff
path: root/kittybox-rs/templates/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-09 22:22:34 +0300
committerVika <vika@fireburn.ru>2023-07-17 01:53:42 +0300
commit99ff9cdc6890959cd4d2112c2e37b97ae83cb43c (patch)
tree31cdaf82de9d95ad4ee857f9148ad442f67db23d /kittybox-rs/templates/Cargo.toml
parentdc7dfc61ec839175ebb51fcbaef1156fea5fdcf4 (diff)
cargo update, part 2: Axum
Axum got some breaking changes and gained some nice features —
however, features come later, breaking changes come first.

Perhaps it would be nice to actually construct a State with all of my
stuff, and then make functions generic over that. Could reduce the
amount of generic stuff I am producing... maybe.
Diffstat (limited to 'kittybox-rs/templates/Cargo.toml')
-rw-r--r--kittybox-rs/templates/Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/kittybox-rs/templates/Cargo.toml b/kittybox-rs/templates/Cargo.toml
index fb123f4..38e73b3 100644
--- a/kittybox-rs/templates/Cargo.toml
+++ b/kittybox-rs/templates/Cargo.toml
@@ -21,7 +21,7 @@ http = "^0.2.7"
 markup = "^0.13.1"
 serde_json = "^1.0.64"
 include_dir = "^0.7.2"
-axum = "^0.5.16"
+axum = "^0.6.18"
 [dependencies.chrono]
 version = "^0.4.19"
 features = ["serde"]