about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-09 22:21:12 +0300
committerVika <vika@fireburn.ru>2023-07-17 01:53:42 +0300
commitdc7dfc61ec839175ebb51fcbaef1156fea5fdcf4 (patch)
tree83c935c793481864b79a6bd482f09b1622cba104 /kittybox-rs/Cargo.toml
parentb38b508366a80a2f1c163ae3623c79e883323201 (diff)
cargo update, part 1
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index 6f7c3c4..1175828 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -11,8 +11,8 @@ default = ["rustls", "postgres"]
 #util = ["anyhow"]
 #migration = ["util"]
 webauthn = ["openssl", "dep:webauthn"]
-openssl = ["reqwest/native-tls-crate", "reqwest/native-tls-alpn", "sqlx/runtime-tokio-native-tls"]
-rustls = ["reqwest/rustls-tls-webpki-roots", "sqlx/runtime-tokio-rustls"]
+openssl = ["reqwest/native-tls-crate", "reqwest/native-tls-alpn", "sqlx/tls-native-tls"]
+rustls = ["reqwest/rustls-tls-webpki-roots", "sqlx/tls-rustls"]
 cli = ["clap"]
 postgres = ["sqlx", "kittybox-util/sqlx"]
 
@@ -71,7 +71,7 @@ rand = "^0.8.5"              # Utilities for random number generation
 tracing-test = "^0.2.2"
 
 [dependencies]
-argon2 = { version = "^0.4.1", features = ["std"] }
+argon2 = { version = "^0.5.0", features = ["std"] }
 async-trait = "^0.1.50"      # Type erasure for async trait methods
 bytes = "^1.1.0"
 data-encoding = "^2.3.2"     # Efficient and customizable data-encoding functions like base64, base32, and hex
@@ -90,7 +90,7 @@ serde_json = "^1.0.64"       # A JSON serialization file format
 serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
 serde_variant = "^0.1.1"     # Retrieve serde provided variant names for enum objects
 relative-path = "^1.5.0"     # Portable relative paths for Rust
-sha2 = "^0.9.8"              # SHA-2 series of algorithms for Rust
+sha2 = "^0.10.7"              # SHA-2 series of algorithms for Rust
 uuid = "^1.3.3"
 tracing = { version = "0.1.34", features = [] }
 tracing-tree = "0.2.1"
@@ -100,10 +100,10 @@ tower-http = { version = "0.3.3", features = ["trace", "cors", "catch-panic"] }
 tower = { version = "0.4.12", features = ["tracing"] }
 webauthn = { version = "0.4.5", package = "webauthn-rs", features = ["danger-allow-state-serialisation"], optional = true }
 [dependencies.tokio]
-version = "^1.16.1"
+version = "^1.29.1"
 features = ["full", "tracing"] # TODO determine if my app doesn't need some features
 #[dependencies.console-subscriber]
-#version = "0.1.3"
+#version = "0.1.10"
 [dependencies.tokio-stream]
 version = "^0.1.8"
 features = ["time", "net"]
@@ -130,7 +130,7 @@ features = ["aio", "tokio-comp"]
 version = "^0.13.0"
 features = ["process"]
 [dependencies.serde]         # A generic serialization/deserialization framework
-version = "^1.0.125"
+version = "^1.0.170"
 features = ["derive"]
 [dependencies.url]           # URL library for Rust, based on the WHATWG URL Standard
 version = "^2.2.1"
@@ -147,12 +147,12 @@ version = "^0.3.0"
 #git = "https://gitlab.com/maxburon/microformats-parser"
 
 [dependencies.clap]
-version = "3.2.22"
+version = "4.3.11"
 features = ["derive"]
 optional = true
 [dependencies.thiserror]
 version = "1.0.35"
 [dependencies.sqlx]
-version = "0.6"
-features = ["uuid", "chrono", "json", "postgres"]
+version = "^0.7"
+features = ["uuid", "chrono", "json", "postgres", "runtime-tokio"]
 optional = true
\ No newline at end of file