about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-07-10 19:35:10 +0300
committerVika <vika@fireburn.ru>2022-07-10 19:35:10 +0300
commit9ca0e358dc95e7358815886b061288f04a7d29af (patch)
treebc19ac6071d75f1ae58069e577fc02692aa87c8b /kittybox-rs/Cargo.toml
parent0ee2072d40dc0b88a7f475a25dfc790d49546a5f (diff)
kittybox-indieauth: init
This crate is the base framework-agnostic implementation of all data
structures and methods required for IndieAuth protocol. Anything that
can deserialize HTTP request payloads with serde can utilize this
crate.

This is a good candidate to independently release on crates.io when
the interface becomes stable enough.
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml7
1 files changed, 5 insertions, 2 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index 6234865..5f23a34 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -27,14 +27,17 @@ required-features = []
 #required-features = ["migration", "redis"]
 
 [workspace]
-members = [".", "./util", "./templates"]
-default-members = [".", "./util", "./templates"]
+members = [".", "./util", "./templates", "./indieauth"]
+default-members = [".", "./util", "./templates", "./indieauth"]
 [dependencies.kittybox-util]
 version = "0.1.0"
 path = "./util"
 [dependencies.kittybox-templates]
 version = "0.1.0"
 path = "./templates"
+[dependencies.kittybox-indieauth]
+version = "0.1.0"
+path = "./indieauth"
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html