about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-07-09 01:32:31 +0300
committerVika <vika@fireburn.ru>2023-07-09 01:32:31 +0300
commit7724c54b4bd8edc9c9cca3e0ae1b459b4550e0fb (patch)
treea88c406d39c36210844d48d2edb7b9c7bb5e83e8 /kittybox-rs/Cargo.toml
parent46a37df2184851f6df35d85b479137caa7d6162b (diff)
main: use tracing_tree in debug builds
This gives me much more readable traces. JSON logging is still
superior in production, where logs are stored in systemd-journald and
preferably need to be self-contained lines.
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index c5aedf1..4c7670d 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -83,6 +83,7 @@ relative-path = "^1.5.0"     # Portable relative paths for Rust
 sha2 = "^0.9.8"              # SHA-2 series of algorithms for Rust
 tracing = { version = "0.1.34", features = [] }
 tracing-tree = "0.2.1"
+tracing-log = "0.1.3"
 tracing-subscriber = { version = "0.3.11", features = ["env-filter", "json"] }
 tower-http = { version = "0.3.3", features = ["trace", "cors", "catch-panic"] }
 tower = { version = "0.4.12", features = ["tracing"] }