about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-07-19 06:16:27 +0300
committerVika <vika@fireburn.ru>2022-07-19 06:16:27 +0300
commit164dbe76c6842245c34ea67b084b2a99aa056b85 (patch)
treeaa7e286bcb3fd187a51758dd6fed6660d4d1a99e /kittybox-rs/Cargo.toml
parent89ed681225e8287cb7ca8d5e92b8ec62c1dd990f (diff)
media: fix small files not being saved to disk properly
It turns out that BufWriter requires calling `flush()` manually and
doesn't do it on `drop()`. I forgot about that.
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index 556a85b..833785c 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -49,6 +49,7 @@ test-logger = "^0.1.0"       # Simple helper to initialize env_logger before uni
 httpmock = "^0.6"            # HTTP mocking library that allows you to simulate responses from HTTP based services
 faker_rand = "^0.1.1"        # Seedable, rand-compatible generators of fake data
 rand = "^0.8.5"              # Utilities for random number generation
+tracing-test = "^0.2.2"
 
 [dependencies]
 async-trait = "^0.1.50"      # Type erasure for async trait methods