about summary refs log tree commit diff
path: root/kittybox-rs/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-07-19 05:27:39 +0300
committerVika <vika@fireburn.ru>2022-07-19 05:32:18 +0300
commit12c96ceaeaabe0aa7d0d2c70497886d9a5610f10 (patch)
tree397b108e44ca16eb402c3725e46a73a8dc1053a3 /kittybox-rs/Cargo.toml
parent1efb89a75af31d7580fdb06e3b4535bcde08e966 (diff)
downloadkittybox-12c96ceaeaabe0aa7d0d2c70497886d9a5610f10.tar.zst
kittybox-indieauth: convert Error into axum::response::Response
This requires the `axum` feature to be enabled, to prevent unwanted
dependencies (e.g. in client apps or when using a different framework,
since the library doesn't concern itself with I/O)
Diffstat (limited to 'kittybox-rs/Cargo.toml')
-rw-r--r--kittybox-rs/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/kittybox-rs/Cargo.toml b/kittybox-rs/Cargo.toml
index 1d1d9fd..556a85b 100644
--- a/kittybox-rs/Cargo.toml
+++ b/kittybox-rs/Cargo.toml
@@ -38,6 +38,7 @@ path = "./templates"
 [dependencies.kittybox-indieauth]
 version = "0.1.0"
 path = "./indieauth"
+features = ["axum"]
 
 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html