about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-04-17 08:56:43 +0300
committerVika <vika@fireburn.ru>2022-04-17 08:56:43 +0300
commite2bc26e907c10def259f52401804f7f6d00c498c (patch)
tree1dcf8001e4eb1e68745ef2e358af32a9a786c4c5 /flake.nix
parentd65a7b6ce9ed74b5dad8c848cdeb49c7635f4062 (diff)
added tokio-console instrumentation support
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index 234a2ae..6c08dab 100644
--- a/flake.nix
+++ b/flake.nix
@@ -187,7 +187,7 @@
     };
     rust-bin = pkgs.rust-bin.stable.latest;
     packages = {
-      kittybox = { stdenv, lib, openssl, pkg-config, naersk-lib }:
+      kittybox = { stdenv, lib, openssl, pkg-config, protobuf, naersk-lib }:
       naersk-lib.buildPackage {
         pname = "kittybox";
         version = "0.1.0";
@@ -195,7 +195,7 @@
         src = ./.;
 
         checkInputs = [ openssl.dev ];
-        nativeBuildInputs = [ pkg-config ];
+        nativeBuildInputs = [ pkg-config protobuf ];
         nativeCheckInputs = [ pkg-config ];
 
         doCheck = stdenv.hostPlatform == stdenv.targetPlatform;
@@ -302,10 +302,10 @@
     devShell = pkgs.mkShell {
       name = "rust-dev-shell";
       nativeBuildInputs = with pkgs; [
-        pkg-config lld
+        pkg-config lld protobuf
         # required for httpmock, not actually used in the release
         openssl.dev
-        xh systemfd
+        xh systemfd tokio-console
         cargo-watch cargo-edit cargo-outdated
         (rust-bin.default.override { extensions = [ "rust-src" ]; })
         (rust-analyzer.override { rustPlatform = with rust-bin; { rustLibSrc = rust-src; }; })