about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2023-02-27 00:09:48 +0300
committerVika <vika@fireburn.ru>2023-02-27 00:09:48 +0300
commitd056148928b5c0ca4cdcb663fca7e143e97a3a41 (patch)
tree7dd2d05a7ac797ca57988dacabb57fed92480c1f /flake.nix
parenteb58228abf97ebca4ebe18d7803cbc2ca4c5df40 (diff)
Flake stuff
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index c4063b8..908f778 100644
--- a/flake.nix
+++ b/flake.nix
@@ -13,6 +13,12 @@
       ref = "master";
       inputs.nixpkgs.follows = "nixpkgs";
     };
+    nixpkgs = {
+      type = "github";
+      owner = "nixos";
+      repo = "nixpkgs";
+      ref = "nixos-22.11";
+    };
   };
   outputs = { self, nixpkgs, flake-utils, naersk }: let
     supportedSystems = ["aarch64-linux" "x86_64-linux"];
@@ -42,7 +48,7 @@
     };
 
     devShells.default = pkgs.callPackage ./shell.nix {
-      inherit (pkgs.nodePackages) typescript;
+      inherit (pkgs.nodePackages) typescript typescript-language-server;
     };
   });
 }