about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2021-08-04 13:58:07 +0300
committerVika <vika@fireburn.ru>2021-08-04 13:58:07 +0300
commitb2961b55cc74607db6e730d8db41a45d9b56c7a7 (patch)
tree8dca741f5a797a666032ea11ce24db3ebbae0b9d /flake.nix
parentc081d65fcea1b4fcf3688d3ab752f62c20c87169 (diff)
Nulls are VERY evil
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 2e3f40d..a3d8c34 100644
--- a/flake.nix
+++ b/flake.nix
@@ -80,10 +80,12 @@
           };
           mediaEndpoint = mkOption {
             type = types.nullOr types.str;
+            default = null;
             description = "The URL of a media endpoint to announce when asked by a Micropub client. Strongly recommended if you plan to upload images.";
           };
           microsubServer = mkOption {
             type = types.nullOr types.str;
+            default = null;
             example = "https://aperture.p3k.io/microsub/69420";
             description = ''
               The URL of your Microsub server, which saves feeds for you
@@ -93,6 +95,7 @@
           };
           webmentionEndpoint = mkOption {
             type = types.nullOr types.str;
+            default = null;
             example = "https://webmention.io/example.com/webmention";
             description = ''
               The URL of your webmention endpoint, which allows you to