about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-05-13 12:33:48 +0300
committerVika <vika@fireburn.ru>2022-05-13 12:33:48 +0300
commita4291c6d896c6653b26bc6a3fe124068de4916e0 (patch)
tree40594dc8089de1a9565de0ff3a38e0ef988d1933 /flake.nix
parent2595205875bfb3de61462ed0b6e5f3bbd6022c74 (diff)
nixos-test: use proper content-type for onboarding
It looks like previous versions did not check Content-Type and I was
able to get away with it. Warp is much more strict in that regard (and
it is good).
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 5d1aed1..05876c6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -251,7 +251,7 @@
 
           with subtest("Onboarding should correctly work..."):
               kittybox.copy_from_host("${./onboarding.json}", "/root/onboarding.json")
-              kittybox.succeed("curl -vvv http://localhost:8080/ -d@/root/onboarding.json")
+              kittybox.succeed("curl -vvv http://localhost:8080/onboarding -d@/root/onboarding.json -H 'Content-Type: application/json'")
               # Testing for a known string is the easiest way to determine that the onboarding worked
               kittybox.succeed("curl --silent http://localhost:8080/ | grep 'vestige of the past long gone'")
         '';