about summary refs log tree commit diff
path: root/distributed-test.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-05-24 17:18:30 +0300
committerVika <vika@fireburn.ru>2022-05-24 17:18:30 +0300
commit5610a5f0bf1a9df02bd3d5b55e2cdebef2440360 (patch)
tree8394bcf1dcc204043d7adeb8dde2e2746977606e /distributed-test.nix
parent2f93873122b47e42f7ee1c38f1f04d052a63599c (diff)
flake.nix: reorganize
 - Kittybox's source code is moved to a subfolder
   - This improves build caching by Nix since it doesn't take changes
     to other files into account
 - Package and test definitions were spun into separate files
   - This makes my flake.nix much easier to navigate
   - This also makes it somewhat possible to use without flakes (but
     it is still not easy, so use flakes!)
 - Some attributes were moved in compliance with Nix 2.8's changes to
   flake schema
Diffstat (limited to 'distributed-test.nix')
-rw-r--r--distributed-test.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/distributed-test.nix b/distributed-test.nix
index 9b62542..539bd0c 100644
--- a/distributed-test.nix
+++ b/distributed-test.nix
@@ -3,7 +3,7 @@
 kittybox:
 { lib, system, ... }: let
   kittyboxModule = { config, pkgs, lib, ... }: {
-    imports = [ kittybox.nixosModule commonModule ];
+    imports = [ kittybox.nixosModules.default commonModule ];
 
     services.kittybox = {
       enable = true;