about summary refs log tree commit diff
path: root/distributed-test.nix
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-05-28 21:05:19 +0300
committerVika <vika@fireburn.ru>2022-06-02 20:59:45 +0300
commit558c4078fd6b5c10bfbcac826774335904807e39 (patch)
treeaab6adef0954241132d556466a40d0066e6d60ed /distributed-test.nix
parentee5b6dca7147c905a79447963761e7cd1f38cabc (diff)
feat: group endpoints under `.kittybox`
Actually got the idea from https://xeiaso.net/, who groups xer
website's endpoints under the `.within` folder.
Diffstat (limited to 'distributed-test.nix')
-rw-r--r--distributed-test.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/distributed-test.nix b/distributed-test.nix
index 539bd0c..39a080b 100644
--- a/distributed-test.nix
+++ b/distributed-test.nix
@@ -12,7 +12,7 @@ kittybox:
       backendUri = "file:///srv/kittybox";
     };
 
-    environment.systemPackages = with pkgs; [ xh curl ];
+    environment.systemPackages = with pkgs; [ xh ];
 
     virtualisation.fileSystems."/srv" = {
       fsType = "nfs";
@@ -80,10 +80,10 @@ in {
 
     # Onboarding
     servants[0].copy_from_host("${./onboarding.json}", "/root/onboarding.json")
-    servants[0].succeed("curl -vvv http://localhost:8080/onboarding -d@/root/onboarding.json -H 'Content-Type: application/json'")
+    servants[0].succeed("xh --follow http://localhost:8080/.kittybox/onboarding -j @/root/onboarding.json")
 
     # Check that all machines got this address onboarded
     for machine in servants:
-        machine.succeed("curl --silent http://localhost:8080/ | grep 'vestige of the past long gone'")
+        machine.succeed("xh http://localhost:8080/ | grep 'vestige of the past long gone'")
   '';
 }