about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-04-17 08:56:43 +0300
committerVika <vika@fireburn.ru>2022-04-17 08:56:43 +0300
commite2bc26e907c10def259f52401804f7f6d00c498c (patch)
tree1dcf8001e4eb1e68745ef2e358af32a9a786c4c5 /Cargo.toml
parentd65a7b6ce9ed74b5dad8c848cdeb49c7635f4062 (diff)
added tokio-console instrumentation support
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 97230a2..61b100e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -61,7 +61,9 @@ sha2 = "^0.9.8"              # SHA-2 series of algorithms for Rust
 warp-prometheus = "^0.5.0"   # An afterthought of prometheus metrics for Warp
 [dependencies.tokio]
 version = "^1.16.1"
-features = ["full"] # TODO determine if my app doesn't need some features
+features = ["full", "tracing"] # TODO determine if my app doesn't need some features
+[dependencies.console-subscriber]
+version = "0.1.3"
 [dependencies.tokio-stream]
 version = "^0.1.8"
 features = ["time", "net"]