about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2021-05-05 16:29:11 +0300
committerVika <vika@fireburn.ru>2021-05-05 16:30:00 +0300
commitdc546640d066dfb7c72d204f3758b103bd415d2c (patch)
tree8b06c539d0d615bd89112478f896d7828542e5eb /Cargo.toml
parent488285e460dba2f5fb0901c77226d582d31e2be4 (diff)
Added a connection pool to the RedisDatabase
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e38cffd..6ce2cbe 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,7 +13,9 @@ tempdir = "0.3.7"           # A library for managing a temporary directory and d
 
 [dependencies]
 # Redis driver for Rust.
-redis = { version = "0.20.0", features = ["aio", "async-std-comp", "r2d2"] }
+#redis = { version = "0.20.0", features = ["aio", "async-std-comp"] }
+# Redis support for the mobc connection pool
+mobc-redis = { version = "0.7.0", features = ["async-std-comp"], default-features = false }
 # A generic serialization/deserialization framework
 serde = { version = "1.0.125", features = ["derive"] }
 # Date and time library for Rust
@@ -36,5 +38,4 @@ newbase60 = "0.1.3"         # A library that implements Tantek Çelik's New Base
 markdown = "0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
 easy-scraper = "0.2.0"      # HTML scraping library focused on ease of use
 serde_urlencoded = "0.7.0"  # `x-www-form-urlencoded` meets Serde
-mobc-redis = "0.7.0"        # Redis support for the mobc connection pool
 mobc = "0.7.2"              # A generic connection pool with async/await support