about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2021-05-05 22:40:01 +0300
committerVika <vika@fireburn.ru>2021-05-05 22:40:01 +0300
commitcbbfca9af1f0aa9da87709f99353fd76fd6617a8 (patch)
tree232f4bfc8682255195dc1a2278e2830db21dd7bb /Cargo.toml
parentdd9d3ff3e9505926e72df7df679cefe960be23bd (diff)
Added rudimentary caching to IndieAuth middleware
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 7 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6ce2cbe..f3b7433 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,8 +12,6 @@ mockito = "0.30.0"          # HTTP mocking for Rust.
 tempdir = "0.3.7"           # A library for managing a temporary directory and deleting all contents when it's dropped.
 
 [dependencies]
-# Redis driver for Rust.
-#redis = { version = "0.20.0", features = ["aio", "async-std-comp"] }
 # Redis support for the mobc connection pool
 mobc-redis = { version = "0.7.0", features = ["async-std-comp"], default-features = false }
 # A generic serialization/deserialization framework
@@ -24,18 +22,19 @@ chrono = { version = "0.4.19", features = ["serde"] }
 url = { version = "2.2.1", features = ["serde"] }
 # Async version of the Rust standard library
 async-std = { version = "1.9.0", features = ["attributes"] }
-lazy_static = "1.4.0"       # A macro for declaring lazily evaluated statics in Rust.
 async-trait = "0.1.50"      # Type erasure for async trait methods
+easy-scraper = "0.2.0"      # HTML scraping library focused on ease of use
 env_logger = "0.8.3"        # A logging implementation for `log` which is configured via an environment variable.
 futures = "0.3.14"          # An implementation of futures and streams
 futures-util = "0.3.14"     # Common utilities and extension traits for the futures-rs library.
 http-types = "2.11.0"       # Common types for HTTP operations.
+lazy_static = "1.4.0"       # A macro for declaring lazily evaluated statics in Rust.
 log = "0.4.14"              # A lightweight logging facade for Rust
+markdown = "0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
+mobc = "0.7.2"              # A generic connection pool with async/await support
+newbase60 = "0.1.3"         # A library that implements Tantek Çelik's New Base 60
+retainer = "0.2.2"          # Minimal async cache in Rust with support for key expirations
 serde_json = "1.0.64"       # A JSON serialization file format
+serde_urlencoded = "0.7.0"  # `x-www-form-urlencoded` meets Serde
 surf = "2.2.0"              # Surf the web - HTTP client framework
 tide = "0.16.0"             # A minimal and pragmatic Rust web application framework built for rapid development
-newbase60 = "0.1.3"         # A library that implements Tantek Çelik's New Base 60
-markdown = "0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
-easy-scraper = "0.2.0"      # HTML scraping library focused on ease of use
-serde_urlencoded = "0.7.0"  # `x-www-form-urlencoded` meets Serde
-mobc = "0.7.2"              # A generic connection pool with async/await support