about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2021-08-06 11:44:46 +0300
committerVika <vika@fireburn.ru>2021-08-06 11:44:46 +0300
commit764d19570ceff8bd11d18ada3d2798f895da2da7 (patch)
tree1ddf223767089389f05c71cec12a952cbcf19980 /Cargo.toml
parent1c1d0e504c276ccb3c204aa28750f86610bff248 (diff)
Added Prometheus instrumentation
I need to instrument the mobc library used for the Redis connection
pool, but that can be done later since I am somewhat tired. I don't
remember how much I've worked and I need a break... >.<
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 4 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7418d90..8556c3b 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -40,7 +40,6 @@ log = "^0.4.14"              # A lightweight logging facade for Rust
 markdown = "^0.3.0"          # Native Rust library for parsing Markdown and (outputting HTML)
 markup = "^0.12.0"           # HTML templating engine... ok also very funny about markdown and markup... i just realized the pun...
 newbase60 = "^0.1.3"         # A library that implements Tantek Çelik's New Base 60
-#prometheus = "^0.12.0"       # Prometheus instrumentation library for Rust applications
 retainer = "^0.2.2"          # Minimal async cache in Rust with support for key expirations
 serde_json = "^1.0.64"       # A JSON serialization file format
 serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
@@ -68,6 +67,10 @@ version = "^0.7.0"
 default-features = false
 features = ["async-std-comp"]
 
+[dependencies.prometheus]    # Prometheus instrumentation library for Rust applications
+version = "^0.12.0"
+features = ["process"]
+
 [dependencies.serde]         # A generic serialization/deserialization framework
 version = "^1.0.125"
 features = ["derive"]