about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2022-03-23 05:01:14 +0300
committerVika <vika@fireburn.ru>2022-03-23 05:01:14 +0300
commit54914782c7632e041919746e80d3f802f6601a63 (patch)
treed54286ddb5424a16921cd0e21cb3917fa47a05a6 /Cargo.toml
parent8964a0330d77fe5a75d33c504791db601d2b0ac7 (diff)
Make the settings in the database a strong type
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 539f973..33f8c2a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -54,6 +54,7 @@ rand = "^0.8.4"              # Random number generators.
 retainer = "^0.2.2"          # Minimal async cache in Rust with support for key expirations
 serde_json = "^1.0.64"       # A JSON serialization file format
 serde_urlencoded = "^0.7.0"  # `x-www-form-urlencoded` meets Serde
+serde_variant = "^0.1.1"     # Retrieve serde provided variant names for enum objects
 relative-path = "^1.5.0"     # Portable relative paths for Rust
 sha2 = "^0.9.8"              # SHA-2 series of algorithms for Rust
 warp-prometheus = "^0.5.0"   # An afterthought of prometheus metrics for Warp