about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2025-01-01 23:17:56 +0300
committerVika <vika@fireburn.ru>2025-01-01 23:17:56 +0300
commitd10710326da703f69eaa06723dc66e330fd32745 (patch)
treee4a32c2a7f2e4a61d1f3f6237977de64e47470ae /Cargo.toml
parent675141379067858376698d5f75ab163977d33e3a (diff)
downloadkittybox-d10710326da703f69eaa06723dc66e330fd32745.tar.zst
axum: 0.7.9 → 0.8.1
Some breaking changes. For better or for worse. The optional extractor
breaking change is a double-edged sword, since not all extractors can
be used with `Option<T>` now, and you have to use
`Result<T, T::Rejection>` even when you want to ignore an error coming
from an extractor, such as `Query`.

However, this allows catching errors on authorization extractors even
in places where authorization is optional.

Change-Id: I35f809d3adf27dbef0e7ee93dc1a7af178b7d014
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 3 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 9d4ba86..20d0f89 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -59,8 +59,8 @@ members = [".", "./util", "./templates", "./indieauth", "./templates-neo", "./to
 default-members = [".", "./util", "./templates", "./indieauth"]
 
 [workspace.dependencies]
-axum = "0.7.9"
-axum-core = "0.4.5"
+axum = "0.8.1"
+axum-core = "0.5.0"
 chrono = { version = "0.4.39", features = ["serde"] }
 clap = "4.5.23"
 data-encoding = "2.6.0"
@@ -124,9 +124,8 @@ wiremock = "0.6.2"
 [dependencies]
 anyhow = { version = "1.0.95", optional = true }
 argon2 = { version = "0.5.3", features = ["std"] }
-async-trait = "0.1.83"
 axum = { workspace = true, features = ["multipart", "json", "form", "macros"] }
-axum-extra = { version = "0.9.6", features = ["cookie", "cookie-signed", "typed-header"] }
+axum-extra = { version = "0.10.0", features = ["cookie", "cookie-signed", "typed-header"] }
 bytes = "1.9.0"
 chrono = { workspace = true }
 clap = { workspace = true, features = ["derive"], optional = true }