about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorVika <vika@fireburn.ru>2025-01-01 05:42:45 +0300
committerVika <vika@fireburn.ru>2025-01-01 07:08:33 +0300
commit5ad8443c8d6d9ed3f9d28ac52af529ceb41d741f (patch)
tree5d6dd326abd9cd135652e68fc893c2a95486a798 /Cargo.toml
parentdf509eadc9aecef605194b7c97c5fb02bf928b79 (diff)
downloadkittybox-5ad8443c8d6d9ed3f9d28ac52af529ceb41d741f.tar.zst
Get rid of base64 and hex in favor of data_encoding crate
Less dependency duplication = more fun

Change-Id: Icbd0497a68fdd5bea3757e3c62c80008b87bce96
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 0 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 18081ac..467ad08 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -124,7 +124,6 @@ argon2 = { version = "0.5.3", features = ["std"] }
 async-trait = "0.1.83"
 axum = { workspace = true, features = ["multipart", "json", "form", "macros"] }
 axum-extra = { version = "0.9.6", features = ["cookie", "cookie-signed", "typed-header"] }
-base64 = "0.22.1"
 bytes = "1.9.0"
 chrono = { workspace = true }
 clap = { workspace = true, features = ["derive"], optional = true }
@@ -132,7 +131,6 @@ data-encoding = { workspace = true }
 either = "1.13.0"
 futures = { workspace = true }
 futures-util = { workspace = true }
-hex = "0.4.3"
 html5ever = "=0.27.0"
 http-cache-reqwest = { version = "0.15.0", default-features = false, features = ["manager-moka"] }
 hyper = "1.5.2"