summary refs log tree commit diff
path: root/pkgs/xtr/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/xtr/default.nix')
-rw-r--r--pkgs/xtr/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/xtr/default.nix b/pkgs/xtr/default.nix
new file mode 100644
index 0000000..1d7a600
--- /dev/null
+++ b/pkgs/xtr/default.nix
@@ -0,0 +1,23 @@
+{ lib, rustPlatform, fetchFromGitHub }:
+rustPlatform.buildRustPackage rec {
+  pname = "xtr";
+  version = "0.1.9";
+
+  src = fetchFromGitHub {
+    owner = "woboq";
+    repo = "tr";
+    rev = "v${version}";
+    hash = "sha256-Un7p8n0+rSyDzEaUGuFXXWUDShR6AZgIYza40ahdZU8=";
+  };
+
+  cargoLock = {
+    lockFile = ./Cargo.lock;
+  };
+  postPatch = "ln -s ${./Cargo.lock} ./Cargo.lock";
+
+  meta = {
+    maintainers = [ lib.maintainers.vikanezrimaya ];
+    license = lib.licenses.agpl3Only;
+    homepage = "https://github.com/woboq/tr";
+  };
+}