summary refs log tree commit diff
path: root/libsecret/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'libsecret/Cargo.toml')
-rw-r--r--libsecret/Cargo.toml95
1 files changed, 95 insertions, 0 deletions
diff --git a/libsecret/Cargo.toml b/libsecret/Cargo.toml
new file mode 100644
index 0000000..93b9a3a
--- /dev/null
+++ b/libsecret/Cargo.toml
@@ -0,0 +1,95 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "libsecret"
+version = "0.6.0"
+authors = [
+    "Bilal Elmoussaoui <bil.elmoussaoui@gmail.com>",
+    "Maximiliano Sandoval <msandova@gnome.org>",
+    "Sophie Herold <sophie@hemio.de>",
+]
+build = false
+exclude = [
+    "gir-files/*",
+    "gir/",
+]
+autobins = false
+autoexamples = false
+autotests = false
+autobenches = false
+description = "Rust bindings of libsecret"
+homepage = "https://world.pages.gitlab.gnome.org/Rust/libsecret-rs"
+documentation = "https://world.pages.gitlab.gnome.org/Rust/libsecret-rs/stable/latest/docs/libsecret"
+readme = "README.md"
+keywords = [
+    "libsecret",
+    "dbus",
+    "secret",
+    "bindings",
+    "freedesktop",
+]
+categories = ["api-bindings"]
+license = "MIT"
+repository = "https://gitlab.gnome.org/World/Rust/libsecret-rs"
+
+[package.metadata.docs.rs]
+all-features = true
+rustc-args = [
+    "--cfg",
+    "docsrs",
+]
+rustdoc-args = [
+    "--cfg",
+    "docsrs",
+]
+
+[lib]
+name = "libsecret"
+path = "src/lib.rs"
+
+[dependencies.ffi]
+version = "0.6"
+package = "libsecret-sys"
+
+[dependencies.gio]
+version = "0.20"
+
+[dependencies.glib]
+version = "0.20"
+
+[dependencies.libc]
+version = "0.2"
+
+[features]
+default = ["v0_18"]
+v0_18 = ["ffi/v0_18"]
+v0_18_6 = [
+    "v0_18",
+    "ffi/v0_18_6",
+]
+v0_19 = [
+    "v0_18_6",
+    "ffi/v0_19",
+]
+v0_20 = [
+    "v0_19",
+    "ffi/v0_20",
+]
+v0_21 = [
+    "v0_20",
+    "ffi/v0_21",
+]
+v0_21_2 = [
+    "v0_21",
+    "ffi/v0_21_2",
+]