summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index c129b56..a1d2a80 100644
--- a/default.nix
+++ b/default.nix
@@ -5,7 +5,7 @@
 
 let
   src = let
-    suffixes = [ ];
+    suffixes = [];
     suffixFilter = name: type: let
       base = baseNameOf (toString name);
     in type == "directory" || lib.any (ext: lib.hasSuffix ext base) suffixes;
@@ -19,6 +19,12 @@ let
   args = {
     # pname and version are read from Cargo.toml
     inherit src;
+    dummySrc = craneLib.mkDummySrc {
+      inherit src;
+      extraDummyScript = ''
+        cp -r ${./icons.toml} $out/icons.toml
+      '';
+    };
     strictDeps = true;
 
     # cargoExtraArgs can be used to inject features
@@ -38,7 +44,7 @@ let
 
 in craneLib.buildPackage (args' // {
   passthru = {
-    inherit cargoArtifacts;
+    inherit src cargoArtifacts;
     clippy = craneLib.cargoClippy args';
   };
 })